快捷搜索:

典型的MPLS 流量工程设置[7206]

Cisco-Edge#sh run

Building configuration...

Current configuration : 8686 bytes

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

hostname Cisco-Edge

boot system slot0:c7200-p-mz.miya.23Jan2002

no logging console

enable password distix

ip subnet-zero

ip cef

mpls label protocol ldp

mpls ldp explicit-null

mpls traffic-eng tunnels #启用MPLS TE

no tag-switching ip propagate-ttl

tag-switching tdp router-id Loopback0 force

interface Loopback0

ip address 10.0.2.1 255.255.255.255

no ip directed-broadcast

interface Tunnel0

ip address 10.10.10.2 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels #在端口上打开MPLS TE feature

tunnel source 10.2.1.2

tunnel destination 10.2.1.2

tunnel mode mpls traffic-eng #指定TUNNEL 的封装类型为mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim #为TUNNEL 指定一条名为name 的显式路径

interface Tunnel1

ip address 10.2.2.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.2.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel2

ip address 10.2.3.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.3.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel3

ip address 10.2.4.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.4.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel4

ip address 10.2.5.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.5.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel5

ip address 10.2.6.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

destination 10.2.6.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel6

ip address 10.2.7.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.7.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel7

ip address 10.2.8.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.8.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel8

ip address 10.2.9.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.9.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel9

ip address 10.2.10.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.10.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel10

ip address 10.2.20.1 255.255.255.252

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.20.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel11

ip address 10.2.11.2 255.255.255.0

no ip directed-broadcast

mpls traffic-eng tunnels

tunnel source 10.2.1.2

tunnel destination 10.2.11.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name Vonly verbatim

interface Tunnel201

no ip address

no ip directed-broadcast

tunnel destination 10.0.2.1

interface POS1/0

ip address 10.2.1.2 255.255.255.0

no ip directed-broadcast

encapsulation ppp

mpls label protocol ldp

tag-switching ip

crc 32

clock source internal

interface FastEthernet2/0

ip address 192.168.201.1 255.255.255.0

no ip directed-broadcast

no keepalive

interface FastEthernet4/0

ip address 192.168.1.101 255.255.255.0

no ip directed-broadcast

router bgp 101

no synchronization

bgp log-neighbor-changes

network 192.168.101.0

neighbor 10.0.2.2 remote-as 102

neighbor 10.0.2.2 ebgp-multihop 2

neighbor 10.0.2.2 update-source Loopback0

neighbor 10.0.2.3 ebgp-multihop 2

neighbor 10.0.2.3 update-source Loopback0

neighbor 10.0.2.4 remote-as 104

neighbor 10.0.2.4 ebgp-multihop 2

neighbor 10.0.2.4 update-source Loopback0

neighbor 10.0.2.5 remote-as 105

neighbor 10.0.2.5 ebgp-multihop 2

neighbor 10.0.2.5 update-source Loopback0

neighbor 10.0.2.6 remote-as 106

neighbor 10.0.2.6 ebgp-multihop 2

neighbor 10.0.2.7 ebgp-multihop 2

neighbor 10.0.2.7 update-source Loopback0

neighbor 10.0.2.8 remote-as 108

neighbor 10.0.2.8 ebgp-multihop 2

neighbor 10.0.2.8 update-source Loopback0

neighbor 10.0.2.9 remote-as 109

neighbor 10.0.2.9 ebgp-multihop 2

neighbor 10.0.2.9 update-source Loopback0

neighbor 10.0.2.10 remote-as 110

neighbor 10.0.2.10 ebgp-multihop 2

neighbor 10.0.2.10 update-source Loopback0

neighbor 10.0.2.11 remote-as 111

neighbor 10.0.2.11 ebgp-multihop 2

neighbor 10.0.2.11 update-source Loopback0

neighbor 10.0.2.20 remote-as 120

neighbor 10.0.2.20 ebgp-multihop 2

neighbor 10.0.2.20 update-source Loopback0

no auto-summary

ip classless

ip route 10.0.0.1 255.255.255.255 10.2.1.1

ip route 10.0.2.1 255.255.255.255 Tunnel0

ip route 10.0.2.1 255.255.255.255 10.2.1.1 200

ip route 10.0.2.2 255.255.255.255 Tunnel1

ip route 10.0.2.2 255.255.255.255 10.2.1.1 200

ip route 10.0.2.4 255.255.255.255 Tunnel3

ip route 10.0.2.4 255.255.255.255 10.2.1.1 200

ip route 10.0.2.5 255.255.255.255 Tunnel4

ip route 10.0.2.5 255.255.255.255 10.2.1.1 200

ip route 10.0.2.6 255.255.255.255 Tunnel5

ip route 10.0.2.6 255.255.255.255 10.2.1.1 200

ip route 10.0.2.7 255.255.255.255 Tunnel6

ip route 10.0.2.7 255.255.255.255 10.2.1.1 200

ip route 10.0.2.8 255.255.255.255 Tunnel7

ip route 10.0.2.8 255.255.255.255 10.2.1.1 200

ip route 10.0.2.9 255.255.255.255 Tunnel8

ip rou

您可能还会对下面的文章感兴趣: